免费刷金币,请点击这里
TE社区 > 数据库
客服QQ:1206116161

Mysql version can not be less than 4.1 出错解决办法

wanghaitang901 于 2018-05-23 16:00:03 创建话题
(3)
(0)
举报

网站出现Mysql version can not be less than 4.1怎么办

最近碰到好多客户都说数据库问题,网站打开提示数据库4.1,这个是怎么回事呢?详细询问了一下,才知道原来如此,这边就给大家分享一下具体解决案例。

网站数据打包上传好,打开出现Mysql version can not be less than 4.1,这个是为什么呢?

错误内容:Mysql version can not be less than 4.1 出现这个提示我们可以翻译一下是什么意思

这个百度翻译过来是:Mysql数据库版本不能低于4.1

提示是数据库有问题,貌似是数据库版本的问题,那么咱们具体可以分析下出现原因。

首先咱们可以看下数据库版本,结果到数据库面板一看,空间的数据库版本是5.1。

那么应该就不是版本的问题,那么怎么还会出现这个提示呢?

其实还有一种可能,那就是我们的数据库是正常的,但是我们网站里面的数据库配置文件有可能跟数据库对不上,也会出现这个提示。

然后我们就需要看下数据库配置文件了,用ftp打开网站根目录,我们找到数据库配置文件,一般是config.inc.php。(也可以是其他文件,这里以此举例说明) 

我们用编辑器打开这个配置文件,可以看到以下数据库配置文件。下面给大家普及一下具体的填写说明:(具体名字可能有些区别,具体区分要注意)

1、数据库地址(database_address),一般程序和数据库都在同一服务器上,写localhost即可.如不在同一服务器, 则填写数据库服务器的IP.

2、数据库用户名(database_username),使用mysql的程序,一般都默认填写的是root,这个是mysql数据库的初始用户,直接使用不太安全, 我们一般都是另外建立一个用户来使用.

3、数据库名(database_tablename),这点需要和数据库用户名区分开来,一个是数据库本身的名字,一个是有权限使用这个数据库的用户的名字, 不能弄混了.

4、数据库密码(database_password),这个数据库用户名的密码.

跟之前我们看到的数据库对比一下,咱们可以看到,原来根本不对,那就可以了。咱们可以修改数据库配置文件为现在的数据库账号密码,如下图:

 [注意,修改的时候一定要注意是否为英文输入模式,复制不要带空格]

感谢阅读,希望能帮助到大家,谢谢大家对本站的支持!

扫码关注TE官方微博 扫码关注TE官方微博
举报X